Начала информатики. Алгоритмический язык программирования ЛОГО. Методическая разработка учителя информатики школы 92 Солодовниковой Т. Я. Начала информатики.


The Presentation inside:

Slide 0

Начала информатики. Алгоритмический язык программирования ЛОГО. Методическая разработка учителя информатики школы № 92 Солодовниковой Т. Я.


Slide 1

Цели: 1. Познакомить с понятиями алгоритм и программа. 2. Познакомить с командами алгоритмического языка ЛОГО. 3. Пробудить желание экспериментировать. Задачи: 1. Научить общению с компьютером в режиме диалога на языке ЛОГО. 2. Научить основам программирования на алгоритмическом языке ЛОГО. 3. Развивать алгоритмическое мышление.


Slide 2

Темы уроков. Урок 1. Введение. Урок 2. Углы и их измерение. Урок 3. «Черепашья графика». Урок 4. Циклы. Урок 5. Построение правильных многоугольников. Урок 6. Построение окружности и дуги. Урок 7. Процедуры. Урок 8. Процедуры с параметрами. Урок 9. Рекурсивные процедуры. Урок 10. Координаты.


Slide 3

Думаем и исследуем на ЛОГО.


Slide 4

Урок 1. Введение.


Slide 5

Немного истории… Язык программирования ЛОГО был разработан в конце 60-х годов американским исследователем в области искусственного интеллекта С. Пейпертом. Название языка происходит от греческого слова «LOGOS» - «слово», «мысль», «смысл», «идея». В языке используется специальный исполнитель команд «черепашка». Она точно выполняет все команды учащегося.


Slide 6

Алгоритм и программа - основные понятия информатики. Алгоритм – конечная последовательность шагов в решении задачи, приводящая от исходных данных к требуемому результату. Алгоритм можно записать в виде нумерованного списка (словесная форма) или изобразить с помощью блок-схемы. Программа – это алгоритм, записанный на языке программирования. Уметь программировать – значит строить алгоритм, т. е. последовательность команд, приводящих к нужному результату, и правильно записывать команды на языке программирования.


Slide 7

Базовые команды черепашки. Черепашку можно научить многим командам, но она имеет и некоторый начальный уровень образованности и выполняет следующие базовые команды вперед, назад, направо, налево.


Slide 8

Запомни: Для выполнения команд вперед и назад необходимо задать черепашке количество шагов (число). Для выполнения команд направо и налево необходимо указать черепашке, на сколько градусов повернуться (число), считая от её текущего положения. Между командой и числом ставится пробел.


Slide 9

Выполним: вперед 100


Slide 10

Выполним: назад 100


Slide 11

Выполним: направо 90


Slide 12

Выполним: налево 90


Slide 13

Урок 2. Углы и их измерение.


Slide 14

Прежде чем попросить черепашку двигаться, нужно обратить внимание на её ориентацию и положение.


Slide 15

Запомни: Ориентацией черепашки называют то направление, куда устремлён её носик. Положение черепашки – это та точка экрана, в которой она находится.


Slide 16

Черепашка, повернись! Черепашка двигаясь по экрану, должна выдержать заданное направление. Поэтому перед движением обязательно задаётся направление движения.


Slide 17

Направо с ю в з 00 900 1800 2700 3600


Slide 18

Налево с ю в з 00 900 1800 2700 3600


Slide 19

Измерить можно - длину отрезка на листе бумаги, - расстояние между городами, - время, - скорость движения поезда, - силу электрического тока, - влажность воздуха, - громкость звука, - температуру окружающей среды, - освещённость помещения и т. д. Сегодня мы научимся измерять угловые величины. Повернём стрелку направо и отметим её новое положение. Между исходной и повёрнутой стрелками образовался угол. Этот угол обозначен цифрой 1. 1


Slide 20

Чтобы точно сравнивать углы и определять их величину, надо научиться их измерять. Посмотрим на часы: По циферблату бежит секундная стрелка. Условимся считать начальным положением стрелки самую верхнюю точку циферблата, отмеченную числом 12. Стрелка пробежала от начального положения полный круг и оказалась опять в точке циферблата, отмеченной числом 12. Такой угол, который соответствует полному обороту стрелки, считают равным 360 градусам. 12 3 9 6


Slide 21

Углы бывают: 900 прямые


Slide 22

Углы бывают: 450 450 300 300 300 300 600 острые


Slide 23

Углы бывают: 1800 1350 тупые развёрнутые


Slide 24

Урок 3. «Черепашья» графика.


Slide 25

Язык ЛОГО имеет большие графические возможности. Перемещаясь по экрану компьютера черепашка может оставлять след, подобно живой черепахе, которая волочит свой хвост по песку. Эту её способность мы будем использовать, чтобы чертить фигуры на экране.


Slide 26

Запомни: Черепашка может двигаться по экрану оставляя след, а может и не оставлять след. Чтобы черепашка оставляла след нужно дать команду Перо Опусти – ПО Чтобы черепашка не оставляла след нужно дать команду Перо Подними – ПП


Slide 27

Задание 1. Научим черепаху рисовать прямоугольник. Одна сторона этого прямоугольника будет 100 шагов, другая - 160 шагов. Все углы у прямоугольника - прямые, значит повороты черепашки при переходе со стороны на сторону будут 90 градусов. 160 100 900 900


Slide 28

Составим алгоритм в виде нумерованного списка (словесная форма): Начало. Вперёд на величину ширины прямоугольника. Поворот на 900 вправо. Вперёд на величину длины прямоугольника. Поворот на 900 вправо. Вперёд на величину ширины прямоугольника. Поворот на 900 вправо. Вперёд на величину длины прямоугольника. Поворот на 900 вправо. Конец.


Slide 29

Черепаха, шагом марш! Напишем программу на языке ЛОГО: по вперед 100 направо 90 вперед 160 направо 90 вперед 100 направо 90 вперед 160 направо 90


Slide 30

Задание 2. А теперь нарисуем квадрат. У квадрата все стороны равны. Сторона квадрата будет 100 шагов. по вперед 100 направо 90 вперед 100 направо 90 вперед 100 направо 90 вперед 100 направо 90 100 900 900


Slide 31

Программировать – значит и редактировать. При построении прямоугольника и квадрата черепашка двигалась, поворачиваясь только Направо. Теперь попросим её нарисовать такие же фигуры, но поворачиваясь только Налево. Для этого отредактируем наши программы, т. е. заменим команду Направо на команду Налево.


Slide 32

Задание 3. Нарисуем лесенку с тремя ступенями. Размер ступеньки по ширине и высоте равен 20. В этом задании черепашка будет двигаться поворачиваясь налево и направо. по вперед 20 направо 90 вперед 20 налево 90 вперед 20 направо 90 вперед 20 налево 90 вперед 20 направо 90 вперед 20 налево 90


Slide 33

Задание 4. Построим равносторонний треугольник. Длина стороны 100 шагов. Все углы в равностороннем треугольнике равны 600 . Составим алгоритм в виде блок-схемы. 100 600 600 600 1200 120 0 1200 Начало Вперед на 100 шагов Направо на 1200 Вперед на 100 шагов Вперед на 100 шагов Направона 1200 Направо на 1200 Конец Блок-схема


Slide 34

Напишем программу на языке ЛОГО: по вперед 100 направо 120 вперед 100 направо 120 вперед 100 направо 120


Slide 35

Задание 5. Построим уголок. Длина линии 50 шагов. по направо 45 вперед 50 направо 90 вперед 50 налево 90 450 900 50 900


Slide 36

Задание 6. Построим фигуру. Длина линии 50 шагов. Угол поворота 900 . по вперед 50 направо 90 вперед 50 направо 90 вперед 50 налево 90 вперед 50 налево 90 50 900 900 900


Slide 37

Урок 4. Циклы.


Slide 38

Цикл – это многократное повторение чего – либо. Например, повторение дней недели, повторение времён года и т. д. В программировании повторяться могут только команды. В ЛОГО – повторение некоторое количество раз одной или нескольких команд обеспечивает команда Повтори


Slide 39

Запомни: Заключённая в квадратные скобки последовательность команд называется телом цикла. При выполнении команды цикла, тело повторяется столько раз, сколько указывает число, стоящее после слова Повтори. Например: Повтори 4[Вперед 100 Направо 90]


Slide 40

Используем команду Повтори для построения фигур. Пример 1. Для построения квадрата команда черепашке будет выглядеть так: повтори 4 [вперед 100 направо 90]


Slide 41

Пример 2. Для построения треугольника команда черепашке будет выглядеть так: повтори 3 [вперед 100 направо 120]


Slide 42

Пример 3. Для построения пяти уголков команда черепашке будет выглядеть так: направо 45 повтори 5 [вперед 50 направо 90 вперед 50 налево 90]


Slide 43

Пример 4. Начертим вертикальную пунктирную линию. Линия содержит 10 пунктиров, длина каждого пунктира 10, расстояние между пунктирами 5. повтори 10 [по вперед 10 пп вперед 5 ] Повторяющаяся часть рисунка 10 5


Slide 44

Пример 5. Начертим горизонтальную пунктирную линию. Линия содержит 10 пунктиров, длина каждого пунктира 10, расстояние между пунктирами 5. направо 90 повтори 10 [по вперед 10 пп вперед 5 ] 900


Slide 45

Пример 6. Какую фигуру начертит черепаха после выполнения команд: по повтори 2 [вперед 50 направо 90 вперед 50 направо 90 вперед 50 налево 90 вперед 50 налево 90]


Slide 46

Черепаха начертит:


Slide 47

Пример 7. Какую фигуру начертит черепаха после выполнения команд: по повтори 5 [вперед 50 направо 90 вперед 50 налево 90]


Slide 48

Черепаха начертит:


Slide 49

Урок 5. Построение правильных многоугольников.


Slide 50

Правильными называются многоугольники, у которых все стороны и углы равны. Чтобы построить любой правильный многоугольник, воспользуемся командой повтори.


Slide 51

Получим значение угла поворота. Для этого 3600 (число градусов в полном круге) разделим на N (число углов многоугольника) 360/N


Slide 52

Получим значение угла поворота: 360/3=120 – для треугольника 360/4=90 – для прямоугольника 360/5=72 – для пятиугольника 360/6=60 – для шестиугольника 360/8=45 – для восьмиугольника


Slide 53

Построим фигуры. 1. Правильный треугольник: повтори 3[ вперед 100 направо 120] 2. Правильный прямоугольник: повтори 4 [вперед 100 направо 90]


Slide 54

Построим фигуры. 3. Правильный пятиугольник: повтори 5[вперед 100 направо 72] 4. Правильный шестиугольник: повтори 6[вперед 100 направо 60] 5. Правильный восьмиугольник: повтори 8[вперед 100 направо 45] :


Slide 55

Урок 6. Построение окружности.


Slide 56

Любую окружность можно считать правильным многоугольником с очень малой стороной и соответственно очень малым углом поворота. Для построения окружности будем использовать команду повтори.


Slide 57

Формула окружности. Для значения угла поворота, равного N, получим формулу окружности: Построим окружность в виде 360-угольника. Найдём угол поворота: 3600/360 = 10 Длину стороны возьмём за 1шаг. Используем команду: повтори 360[вперед 1 направо 1] : повтори 360/N [вперед 1 направо N]


Slide 58

Пользуясь формулой окружности заполним таблицы: Уменьшение Увеличение окружности: окружности:


Slide 59

Построим окружности разного размера пользуясь данными таблиц: Повтори 180 [вперед 1 направо 2] Повтори 400 [ вперед 1 направо 0.9] Повтори 36 [ вперед 1 направо 10] Повтори 514 [ вперед 1 направо 0.7] Повтори 120 [ вперед 1 направо 3]


Slide 60

Построение дуги. Дуга – это часть окружности.


Slide 61

Например: 1. Эта дуга – половина окружности, поэтому количество повторений надо уменьшить в два раза: повтори 180 [вперед 1 направо 1] 2. Эта дуга – четверть окружности, поэтому количество повторений надо уменьшить в четыре раза: повтори 90 [вперед 1 направо 1] 1800 900


Slide 62

Задание. Построить дугу, которая составляет восьмую часть окружности. повтори 45 [вперед 1 направо 1]


Slide 63

Урок 7. Процедуры.


Slide 64

Процедура – это последовательность известных черепашке (базовых) команд, имеющая имя. По этому имени процедуру можно вызывать, т. е. выполнять все входящие в неё команды.


Slide 65

Запомни: Процедура состоит из трёх частей: 1. Заголовок процедуры. 2. Тело процедуры (описание). 3. Окончание процедуры.


Slide 66

Запомни: Заголовок процедуры пишется на отдельной строке и составляется из обязательного слова ЭТО, за которым указывается имя процедуры. Тело процедуры – все команды, расположенные между заголовком и окончанием. Окончание процедуры – слово КОНЕЦ.


Slide 67

Вызов процедуры. Имя процедуры, использованное в качестве команды, называется вызовом процедуры.


Slide 68

Задание 1. Составим процедуру квадрат: это квадрат по повтори 4 [вперед 100 направо 90] конец Вызов процедуры - квадрат


Slide 69

Задание 2. С помощью процедуры квадрат изобразить квадрат, повёрнутый на 45 градусов: направо 45 квадрат


Slide 70

Задание 3. Используя процедуру квадрат заставить квадрат покружиться на месте: повтори 18 [квадрат направо 20]


Slide 71

Задание 4. Составить процедуру дуга и используя эту процедуру нарисовать лепесток . это дуга по повтори 45 [вперед 1 направо 2] конец дуга направо 90 дуга


Slide 72

Задание 5. Имея описание процедуры дуга напишите программу, которая рисует цветочек, состоящий из четырёх лепестков:


Slide 73

Программа на ЛОГО: это дуга по повтори 45[ вперед 1 направо 2] конец повтори 4 [дуга направо 90 дуга]


Slide 74

Задание 6. Имея описание процедуры дуга, нарисовать море:


Slide 75

Программа на ЛОГО: это дуга по повтори 180 [вперед 1 направо 1] конец повтори 5 [дуга налево 180]


Slide 76

Урок 8. Процедуры и параметры.


Slide 77

Составим процедуру, которая будет рисовать квадрат, но вместо конкретного количества шагов, определяющего размер квадрата, поставим параметр - переменную, значение которой можно изменять.


Slide 78

Процедура с параметром: это квадрат :сторона повтори 4 [вперед :сторона направо 90] конец Параметр :сторона указан в заголовке процедуры вслед за её именем. Этот же параметр встречается (обязательно) и в теле процедуры, в том месте, где предусмотрено использование переменной величины.


Slide 79

Запомни: Переменную можно представить себе как ящик, на котором написано имя, а внутри находится значение. Это значение можно изменять. Перед именем переменной ставится двоеточие, пробел между двоеточием и именем переменной не допускается.


Slide 80

Переменные в процедурах называются параметрами. - Значения параметров внутри процедуры не меняются. - Параметры, указываемые в описании процедуры ( в её заголовке и в теле), называют формальными параметрами её описания. - Формальный параметр всегда представляет собой имя некоторой величины.


Slide 81

Запомни: В момент вызова процедуры с параметрами надо указать значение этого параметра: квадрат 100 Это значит, что значение переменной для команды вперед следует взять из переменной сторона, которая стоит в заголовке процедуры.


Slide 82

Значение величины, указываемое при вызове процедуры называется фактическим параметром или параметром вызова процедуры. Фактический параметр всегда является значением, заменяющим собой формальный параметр в описании процедуры; с этим значением параметра и выполняется вызванная процедура.


Slide 83

Процедура с несколькими параметрами. Пример 1. Составим описание процедуры, рисующей прямоугольник, длина и высота которого произвольны: это прямоугольник :высота :длина повтори 2 [вперед :высота направо 90 вперед :длина направо 90] конец Вызов процедуры: прямоугольник 50 100 прямоугольник


Slide 84

Пример 2. Составим процедуру, которая будет рисовать любой правильный многоугольник, но вместо конкретного количества повторений, количества шагов и угла поворота поставим переменные, значение которых можно изменять: это многоугольник :число :сторона :угол повтори :число [вперед :сторона направо :угол] конец Вызов процедуры: многоугольник 6 100 60 шестиугольник


Slide 85

Урок 9. Рекурсивные процедуры


Slide 86

Мы уже знаем, как заставить черепаху начертить круговую орбиту: это орбита повтори 360 [ вперед 1 направо 1] конец Но как заставить её кружить по этой орбите подобно спутнику? Для этого после того, как черепаха начертит окружность, она снова должна выполнить процедуру орбита: это орбита повтори 360 [вперед 1 направо 1] орбита конец


Slide 87

Запомни: Процедуры которые вызывают сами себя называются рекурсивными.


Slide 88

Рекурсивная процедура выполняется бесконечно… Прервать программу можно одновременным нажатием клавиш <Ctrl > и <Break>


Slide 89

Бесконечное движение черепашки по треугольной орбите: это треугольник повтори 3 [вперед 100 направо 120] треугольник конец


Slide 90

Бесконечное движение черепашки по квадратной орбите: это квадрат повтори 4 [вперед 100 направо 90] квадрат конец


Slide 91

Урок 10. Координаты.


Slide 92

Запомни: Два числа, определяющие положение точки на плоскости, называются координатами. Плоскость с отмеченной на ней точкой начала отсчёта и проходящими через эту точку двумя линиями, называется системой координат. Точку начала отсчёта называют началом координат. Направленные линии – осями координат.


Slide 93

Запомни: Для того, чтобы точка могла быть точно определена парой координат, первым элементом пары всегда является величина Х (абсцисса точки), а вторым элементом – всегда величина У (ордината точки).


Slide 94

(0, 0) у х Ось абсцисс Ось ординат А(х, у) 372 213 -372 -213 Размеры экрана: II четверть I четверть III четверть IV четверть


Slide 95

Оси координат разбивают плоскость на четыре части, которые называются координатными четвертями. Мы будем работать только в первой координатной четверти у х I четверть Координаты центра экрана [0 0]


Slide 96

Внимание! Решая задачи с использованием координат, мы не будем пользоваться командами вперед, назад, направо, налево. Новые команды: покажи место – сообщает координаты точки, в которой находиться черепашка; нов_место [х у] – перемещает черепашку в точку с координатами [х у]; нов_у число – изменяет у-координату черепашки; нов_х число – изменяет х-координату черепашки; Передвигаясь от точки к точке черепашка может оставлять след, а может не оставлять след.


Slide 97

Пример 1. Построить квадрат, пользуясь координатами его вершин. (0,0) 10 60 10 60 у х (10,10) (10,60) (60,60) (60,10) пп нов_место [10 10] по нов_место [10 60] нов_место [60 60] нов_место [60 10] нов_место [10 10] Программа на ЛОГО:


Slide 98

Пример 2. Даны координаты пятнадцати точек. Построить фигуру по этим координатам. (40,10) (40,20) (10,20) (40,50) (20,50) (40,70) (30,70) (50,90) (70,70) (60,70) (80,50) (60,50) (90,20) (60,20) (60,10) пп нов_место [40 10] по нов_место [ 40 20 ] нов_место [ 10 2 0] нов_место [ 40 5 0] нов_место [ 20 50 ] нов_место [ 40 70 ] нов_место [ 30 70 ] нов_место [ 50 9 0] нов_место [ 70 70 ] нов_место [ 60 7 0] нов_место [ 80 5 0] нов_место [ 60 5 0] нов_место [ 90 20 ] нов_место [ 60 20 ] нов_место [ 60 10 ] Программа на ЛОГО:


Slide 99

Черепашка построит: х у 0


Slide 100

Пример 3. Даны координаты двенадцати точек. Построить фигуру по этим координатам. (30, 60) (60, 30) (150, 30) (180, 60) (100, 60) (100, 160) (130, 160) (120, 150) (130, 140) (100, 140) (160, 60) (30, 60) Программа на ЛОГО: пп нов_место [30 60] По нов_место [ 60 30] нов_место [ 150 30] нов_место [ 180 60] нов_место [ 100 60] нов_место [ 100 160] нов_место [ 130 160] нов_место [ 120 150] нов_место [ 130 140] нов_место [ 100 140] нов_место [ 160 60] нов_место [ 30 60]


Slide 101

Черепашка построит: х у 0


Slide 102

Слышу – и забываю, вижу – и запоминаю, делаю – и понимаю. (Восточная мудрость)


×

HTML:





Ссылка: