Система Logo Writer


The Presentation inside:

Slide 0

Система Logo Writer


Slide 1

Программирование в среде ЛОГО Каждая программа для компьютера разрабатывается на одном из языков – языков программирования. ЛОГО – образовано от древнегреческого «logos», что означает «мысль», «слово». Язык ЛОГО состоит из: алфавита (буквы – русские, цифры, символы) специально встроенные слова (команды- предложения на языке программирования для указания действия объекту)


Slide 2

Лист оглавления системыLogo Writer Logo_NEW ОГЛАВЛЕНИЕ С помощью клавиш выберите лист и нажмите клавишу Ввод Новый лист Формы


Slide 3

Интерфейс программы ЛОГО Рабочее поле Командный центр - для ввода команд на языке ЛОГО Исполнитель «Черепашка» На рабочем поле отображается исполнитель (черепашка) и результаты его действия Расстояние на рабочем поле измеряется в шагах Черепашки. Один шаг – один пиксель.


Slide 4

Правила записи команд На первом месте пишется название команды, а затем указывается параметры Параметры команды – слово, число или выражение, уточняющее действие команды Вперед 50 Команда Параметр Название команды должно быть написано без ошибок – точно как в словаре. Между буквами в названии команды не должно быть пробелов. Если в команде есть параметр, то он отделяется от названия пробелом, если в одной строке записывается несколько команд, то они разделяются пробелами.


Slide 5

?Ввод команды или последовательности команд должен заканчиваться нажатием клавиши «Enter». ?»ЧИСЛО» в командах вперёд, назад, налево, направо может быть как положительным, так и отрицательным!


Slide 6

Команды для графического исполнителя


Slide 7

КОМАНДЫ ИСПОЛНИТЕЛЮ (черепашке) СЧ – «Спрячь Черепашку» ПЧ -«Покажи Черепашку» ИГ - «Исходная Графика»


Slide 8

СОКРАЩЁННЫЕ ФОРМЫ ЗАПИСИ СЛУЖЕБНЫХ СЛОВ


Slide 9

ПОВОРОТЫ ЧЕРЕПАШКИ НАПРАВО 90 НАЛЕВО 90 направо -45 НАПРАВО-135


Slide 10

Команды НАЗАД 90 и ВПЕРЁД 90 90 90 НАЗАД 90 ВПЕРЁД 90


Slide 11

Задача. Укажите последовательность команд для вычерчивания квадрата со стороной 40. Решение. Иг Вперед 40 направо 90 Вперед 40 направо 90 Вперед 40 направо 90 Вперед 40 направо 90 сч


Slide 12

Задание. Укажите последовательность команд для вычерчивания фигуры «одним росчерком пера»:


Slide 13

назад 40 направо 90 вперед 20 налево 90 вперед 40 назад 40 налево 90 вперед 40 направо 90 вперед 40 назад 40 направо 90 вперед 20 направо 90 вперед 120


Slide 14


Slide 15

60 60 60 60 60 40 80 40 40 40 40 40 40 40 40 40 40


Slide 16

Организация циклов в среде LogoWriter


Slide 17

Задача. Укажите последовательность команд для вычерчивания квадрата со стороной 40. Решение. Иг Вперед 40 пр 90 Вперед 40 пр 90 Вперед 40 пр 90 Вперед 40 пр 90 сч


Slide 18

повтори <число> [список команд] Иг повтори 4 [Вперед 40 пр 90] Задача: укажите последовательность команд , вычерчивающих равносторонний треугольник. Команда повтори


Slide 19

Иг повтори360 [Вперед 1 пр 1] сч Вычерчивание окружности.


Slide 20

Иг повтори 4 [повтори 180 [Вп 1 пр 2] пр 90] сч


Slide 21

пусть “S 0 пусть “N 1 повтори 12 [вп :N пусть “S :S +:N пусть “N :N + 2] ?


Slide 22


Slide 23

Понятие процедуры. Процедура – подпрограмма( программа, которую вызывают другие программы). Пример: это квадрат повтори 4[вперед 40 направо 90] конец Процедура состоит: 1)из заголовка( служебное слово это и имя процедуры). 2)последовательности команд 3)служебного слова конец.


Slide 24

Правила записи процедуры. Заголовок и служебное слово конец должны размещаться на отдельных строках. Для записи процедуры предназначена изнаночная сторона листа. Переход с одной стороны листа на другую осуществляется либо по команде переверни , либо по нажатию клавиш<Ctrl>+<F>


Slide 25

Вызов процедуры. Для вызова процедуры предназначена лицевая сторона листа: набрать в поле команд имя процедуры. Задание: составьте процедуру вычерчивания прямоугольника со сторонами 50 и 40; составьте процедуру вычерчивания треугольника со стороной 40; К процедуре можно обращаться из последующих процедур. составьте процедуру , рисующую домик, используя две предыдущие процедуры.


Slide 26

Домик


Slide 27

Вложенные процедуры. это прямоугольник повтори 2[вп 50 пр 90 вп 40 пр 90] конец это треугольник вп 40 лв 120 вп 40 лв 120 вп 40 конец Это домик прямоугольник вп 51 пр 90 треугольник конец домик- головная процедура; треугольник, прямоугольник - вложенные процедуры.


Slide 28

Написать процедуру составления узора из квадрата со стороной 20. это квадрат повтори 4[вп 20 пр 90] конец


Slide 29

узор это узор пп лв 90 вп 20 пр90 по (переместили черепашку влево на один квадрат) повтори 3[квадрат пп пр 90 вп 20 лв 90 вп 10 пр 45 по квадрат пп лв 90 нд 20 пр 90 вп 20 лв 45 нд 10 по] сч конец


Slide 30

задание: уменьшить сторону квадрата до 10 пикселей, количество фрагментов узора увеличить вдвое. Задание 2: нарисовать пятиконечную звезду (угол звезды 360)


Slide 31

назначение функциональных клавиш при наборе процедур <F6>удаление символов от курсора до конца строки <F5>переключение алфавита <F1>включение режима выделения текста <F2>запись выделенного фрагмента в буфер( текст с экрана исчезает) (вырезать) <F3>то же(текст не исчезает) (копировать) <F4>вывод на экран с позиции курсора фрагмента из буфера


Slide 32


×

HTML:





Ссылка: